Custom Fighters - Custom Streetfighter Motorcycle Forum banner
1 - 9 of 9 Posts

·
Newbie
Joined
·
79 Posts
Discussion Starter · #1 ·
Went out for a ride and after stopping bike wouldn't start. Every time I hit the starter I can hear the relay click once. I was able to bump start it and get home.

First thing I did was try my buddy's battery and still same one click after pressing starter.

Thought it could be the starter motor so took it out and bench tested it. Motor spun when I applied power. Before reinstalling starter motor I cleaned + and - wires.

Maybe bad relay so bought a new one and just installed it. Same click.

Dash lights up no problem when I turn the key on.

Only other issue I was having was I would have to jiggle the neutral switch on occasion for the idiot light to show I was in neutral.

My buddy's bike is an SV650 and I have 99 cbr 900. The model of battery is different but it would still start my bike I assume.

Thanks in advance if anyone has any ideas.
 

·
Fuck it, let's do it live
Joined
·
3,993 Posts
Grounds all good?
 

·
Newbie
Joined
·
79 Posts
Discussion Starter · #3 ·
So far the only ones I've cleaned and reconnected is the ground from the relay to the starter motor and the neutral switch ground which was also connected to the starter. Which other grounds should I check?

Checked all fuses and they are good.
 

·
Registered
Joined
·
78 Posts
chester bbb

So I had the exact same problem on my 95 CBR 900rr and I replaced the starter relay and that didn't work.

What it ended up being was the positive connection from the Battery to the Starter was lose/not making a solid connection. Cleaned the bolts and tightened the nut and have had no issue since.

I thought it was amazing something so simple. Bought the relay and didn't even need it.

hope this helps.
 
1 - 9 of 9 Posts
Top