Custom Fighters - Custom Streetfighter Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello Everyone, My name is John. So, to start out i am new to the CBR seen. I have a Harley and was raised on them all my life. I just came into position of a 1987 CBR 600 Caine. It is pretty cool, and I have been putting in a lot of hours the last two weeks trying to get it drivable. I finally got carbs all put back together and on, fired it up for the first time, it ran great all considered. In the picture it has the front fairing on it, and I also have all other plastic, but plan on going the street fighter look. I would love any input on good ideas to do to it, I need a new speed cluster that is reasonable, I have been looking at the Acewell brand and also the danmoto one, if you guys know of a better cheaper one let me know. I know this is not a trouble shooting section but after firing it up today and ridding it for the first time it over heated and coolant boiled out overflow, what would cause this I checked the oil (even though I changed it the day I got it and put the recommended 3.5 quarts in) it was about 1.5 quarts low… could that have been the problem? All your input and help will be appreciated and I plan on starting a build thread soon.:CK187:
ps:the other pic is the new streetfighter fairing i ordered let me know what you think.
 

Attachments

·
The one and only.
Joined
·
685 Posts
a lot of people (including myself) have used a bicycle speedometer. its pretty simple to get it set up and they cost about $10-$20.

i would completely clean the bike (if you havent done so already) then go for a little ride (KEEP your eye on the temps!) then it will be a bit easier to see where/if its leaking any fluids. maybe check the raditor?


welcome to the site!
 
  • Like
Reactions: oldrider

·
Administrator
Joined
·
50,493 Posts
welcom in John',check yer rad cap is sealing well and that yer fan is workin properly .
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Thanks all for the input. I know it's not leaking, but I also no the fan is not working so I will figure out what's wrong with that today, as far as the light it's alright for now I think I am going to mod it so I can put the stock lightbulb in it.


Sent from my iPod touch using MO Free
 

·
Fooking old git
Joined
·
2,216 Posts
Thanks all for the input. I know it's not leaking, but I also no the fan is not working so I will figure out what's wrong with that today, as far as the light it's alright for now I think I am going to mod it so I can put the stock lightbulb in it.


Sent from my iPod touch using MO Free
Rethink the light.

Take of the rad cap and rev the engine, if water is pushed out of the rad it could be a head gasket, if it just throws a little bit that s normal so check the thermostat.
Also does the coolant have oil in it and is the rad cap clean.
 

·
Premium Member
Joined
·
20,726 Posts
Welcome to CF! Good luck with figuring out the problem....:D
 

·
Function IS Form
Joined
·
17,406 Posts
Did you check the oil while it was running? A lot of people don't realize that the sightglass may be empty while the bike is running, and often right after shutting it off.
 
1 - 9 of 9 Posts
Top