Custom Fighters - Custom Streetfighter Motorcycle Forum banner
1 - 3 of 3 Posts

·
Is my bike ok?
Joined
·
15,255 Posts
Discussion Starter · #1 ·
This things fires up and runs like a champ. Sounds like a beast.

The front end is tight and the CV shafts are healthy.

Front and rear racks are straight and solid.

Brand new 2500lb winch with wireless remote control.

2'' of lift

28x12 Outlaw Highlifter tires.

12'' ITP alloy wheels.

All lights work and the four wheel drive works.

FMF Powerline exhaust and properly rejetted. Fires up,idles and WOT's like nobody's business.

Fresh battery

*The bad:

Four wheel drive indicator doesn't light up when engaged. All others are fine.

Thumbshift no longer works and has been converted to foot shift. Goes in R & 1-5 just fine.

Rear brake not working-pedal does not move.

Plastics are fair (rear fender extensions have been trimmed,engine covers are missing,grille is homemade,left side foot tub works,but is patched together) Hey...it's a mud machine...but a good looking 20-footer for sure.

I have no clue what's wrong with the rear brake and I don't have the time to look at it (it's not even at my house),so it's priced accordingly. I ran the poo out of it to see if it had any running issues and never had trouble stopping this tank with the front dual discs alone.

*The supposed: engine has supposedly had a bigbore kit in it. I was told .060 over,but the PO couldn't produce paperwork, so I can't verify that myself. Just putting it out there. Does seem to have great power,though.

$2,500 obo. No trades. Located at Roanoke Cycle Sports on Williamson Road,Roanoke VA 540-362-0063 Thanks for looking :)










 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top