Custom Fighters - Custom Streetfighter Motorcycle Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey guys,

Anyone have any experience wiring up the koso db-01r to an 09 ninja 650r? When I first wired it up I wasn't using their sensor. Everything was working fine except that I was getting crazy speed readings, like 225mph. I emailed koso and they said I had to use their sensor to fix that. So now I've wired their sensor up and the speedometer is reading 0 all the time. Also, I have lost the tachometer. Any advice from someone out there who has made this thing work?

Thanks.
 

·
Registered
Joined
·
114 Posts
Koso are a pain in the ass!

You can use the factory speed sensor but only if it picks up less than 20points per cycle. I ran my old one off my fz6 speed sensor and it was also giving me way over the top readings, all i did was to figure out my speedo speed with a gps at 10,20,30,50,70 mph, worked out the percentage it was out by and then changed the tire circumfrence setting by that percentage and it read pretty spot on after that.

Presumably the mileage etc was then way out, but i didnt care too much about that!

Have you rest the Koso and set it up to run with their sensor? if not you'll need to do that, or possibly check the distance between sensor and magnet make sure thats close enough etc.

Good luck!
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Yea I finally got it working by hooking up their sensor. It just would not work properly without it. When they say that the sensor has to be directly over the center of the magnet they are not kidding. It has to be DIRECTLY over the magnet to read correctly. Now if I can just find a nice way to mount it to make that possible I'll be good to go.

Anyone have an idea of t=what the tach sensor setting should be for the 650r? I read somewhere it should be 4C (coils), 2P (pistons). Can anyone confirm? Haven't had a chance to mess with that yet.
 
1 - 3 of 3 Posts
Top