Custom Fighters - Custom Streetfighter Motorcycle Forum banner

1 - 20 of 35 Posts

·
Gsxr nut
Joined
·
460 Posts
Discussion Starter · #1 ·
So I finally got my 02 600 gixxer back together after being all torn apart. I turn the key on and the fuel pump doesn't hum and the FI light is on..... It wont turn over at all either. Obvious things I've checked: all fuses, and made sure all connections were put together. This is the same harness that was on there the last time ran it.... Also tried swaping computers and fuel pump relays with no difference made. Im lost guys any ideas?:help0:
 

·
Registered
Joined
·
4,653 Posts
Fuck it just light it on fire and roll it down the street
 

·
Bitches love Fighters
Joined
·
5,325 Posts
lights coming on? headlights and gauge lights that is. if the fuel pump doesnt prime AND it doesnt do anything when you try to start it then the ignition circuit isnt getting power. check the ignition fuse again and replace it. ive blown fuses and not known because they looked fine. side stand switch when open will still let the pump prime. even if its in gear. same with the clutch safety switch or neutral safety switch. so that leaves a few things. the ignition fuse and wiring. the killswitch. or the tip over sensor.
 
  • Like
Reactions: MikeGyver

·
fatass needs corndogs
Joined
·
436 Posts
Also check the battery connections. Clean them and then put them back on good and tight with good connection. Bad connections will let little things work but not high pull items like starters and such.
 

·
Gsxr nut
Joined
·
460 Posts
Discussion Starter · #16 ·
Also check the battery connections. Clean them and then put them back on good and tight with good connection. Bad connections will let little things work but not high pull items like starters and such.
I will try that as well! But back to the fact that my gauge does not show a neutral light... Would that not let my fuel pump come on?
 

·
fatass needs corndogs
Joined
·
436 Posts
Fuel pump should build pressure no matter what provided everything is hooked up. The safeties are on other functions like clutch and kickstand.
 

·
Elbow Grease is Cheap
Joined
·
6,370 Posts
I will try that as well! But back to the fact that my gauge does not show a neutral light... Would that not let my fuel pump come on?

This is why I said to check your gauge connections.

lack of a good cluster connection left me and the 675 stranded on the side of the road until I figured it out. SAME ISSUES you are experiencing. Gear selector/N light not functioning, no fuel pump priming, no starter.
I unplugged the connection and plugged it back in, and it fired right up.
 

·
Bitches love Fighters
Joined
·
5,325 Posts
this neutral light is a big thing with gsxrs from the srad up. both srad motors i had would do it now and then. my 08 1000 does it now and then. ive even seen brand new ones do it. that light has nothing to do with the fuel pump though. no matter what gear its in. kickstand up or down. clutch lever in or out. when you turn the key and flip the kill switch the pump will prime. the only things that will cause your pump not to prime are the tip over sensor, not having the pump plugged in (yes ive done that) faulty kill switch, blown ignition fuse or main fuse, faulty wiring in that circuit or the fuel pump wiring, or a dead fuel pump. of those the only things that would cause the starter not to spin are the blown ignition or main fuse, faulty switch, or faulty wiring. i believe the starter should still spin with the TOS stuck

to bypass the tip over sensor take it apart-inside theres a metal ring that slides over a metal rod. put a zip tie on each side of the metal ring so that it cant slide or contact the metal rod it slides over-take it apart and youll see what im talking about. You can also fill it with jbweld or silicone.

i actually had this very thing happen to me the other day on a ride. stopped at a natural spring outlet for a drink. came back out, key on. kill switch on and no pump prime or starter spin. it was my ignition fuse
 
1 - 20 of 35 Posts
Top