Custom Fighters - Custom Streetfighter Motorcycle Forum banner

1 - 7 of 7 Posts

·
Newbie
Joined
·
79 Posts
Discussion Starter · #1 ·
Had a bad reg/rec that fried my battery and left me stranded. My gauge was reading between 18-20volts at about 65mph before it died. Replaced reg/rec and battery and bike turns over fine but won't fire. Smell a little bit of gas also from exhaust.

Is it possible that my cdi was fried along with the battery. Is there any way to test the unit. I looked through my oem and Clymer manual and didn't find any info.
 

·
Bitches love Fighters
Joined
·
5,325 Posts
could be. have you checked to see if you are getting spark?
 

·
"Detonation"
Joined
·
1,034 Posts
i've just gone threw this whole problem myself mate.

Somehow it fried my CDI & My right coil

You cant really test a CDI other than narrowing it down to that by testing other things.
 

·
Newbie
Joined
·
79 Posts
Discussion Starter · #4 ·
i've just gone threw this whole problem myself mate.

Somehow it fried my CDI & My right coil

You cant really test a CDI other than narrowing it down to that by testing other things.
Damn right coil too. I just ordered another CDI and pray it's just that. From Honda $490 before tax and $150 off ebay new & OEM.
 

·
I R smart.
Joined
·
562 Posts
I've seen some coils ve forgiving to being overdriven up to 24 volts for short periods of time. but I'm willing to place money on the CDI being fried. They are extremely sensitive to voltage spikes and RFD blowback from the coils. I have a bad coil that was blowing back into the CDI and trashed it on my ZX.
 
1 - 7 of 7 Posts
Top